hpsa: monitoring on debian/ubuntu server

After kernel version 2.6.33 for HP SmartArray storage controllers the driver changed.
Actually cciss is a driver for a raid controller, the new hpsa is a driver for SCSI/SATA/SAS block devices.


Also this changes the device names: /dev/cciss/c0d1p1 -> /dev/sda1 .
However this can be configured with a driver paramater.

Unfortunately not all of the utilities can be used anymore. For example arrayprobe is compatible with the new driver.
Fortunately HP’s official utilities are still available and usable:

http://downloads.linux.hp.com/SDR/psp/pool/non-free/

check_hparray for nagios:

wget 'http://exchange.nagios.org/components/com_mtree/attachment.php?link_id=674&cf_id=24' -O check_hparray

Far better using apt:
/etc/apt/sources.list.d/hp.list

deb http://downloads.linux.hp.com/SDR/psp/ [lucid|lenny] current/non-free

Lucid packages can be used on Natty and probably Lenny on Squeeze.

avatar

About tompos

Hungary, Budapest
This entry was posted in IT, Linux, Ubuntu. Bookmark the permalink.

Leave a Reply